Wednesday, March 8, 2017

Back to Virtual NetBSD


I was mistaken in my last post about Openindiana. It appears to compile, but never reaches the point where the final packages are made. It's probably a problem with my sunstudio setup -I don't feel like chasing it down when there's alternatives to play with.

I'm very fond of NetBSD -have been for fifteen or so years now.

Sadly, for nine and a half years I haven't been able to get it to work with real hardware. At first it didn't like my sata drives (in a computer now long-since gone), these days it doesn't like my wifi or my wireless mouse.

...thank God for virtualization, huh?

make release started at:  Wed Mar  8 00:49:50 AKST 2017
make release finished at: Wed Mar  8 02:16:35 AKST 2017
===> Successful make release
===> build.sh ended:      Wed Mar  8 02:16:35 AKST 2017
===> Summary of results:
         build.sh command:    ./build.sh -x -j 6 -r release
         build.sh started:    Wed Mar  8 00:49:44 AKST 2017
         NetBSD version:      7.1_RC2
         MACHINE:             amd64
         MACHINE_ARCH:        x86_64
         Build platform:      NetBSD 7.1_RC2 amd64
         HOST_SH:             /bin/sh
         No $TOOLDIR/bin/nbmake, needs building.
         Bootstrapping nbmake
         MAKECONF file:       /etc/mk.conf
         TOOLDIR path:        /usr/src/obj/tooldir.NetBSD-7.1_RC2-amd64
         DESTDIR path:        /usr/src/obj/destdir.amd64
         RELEASEDIR path:     /usr/src/obj/releasedir
         Removing /usr/src/obj/tooldir.NetBSD-7.1_RC2-amd64
         Removing /usr/src/obj/destdir.amd64
         Created /usr/src/obj/tooldir.NetBSD-7.1_RC2-amd64/bin/nbmake
         Updated makewrapper: /usr/src/obj/tooldir.NetBSD-7.1_RC2-amd64/bin/nbmake-amd64
         Successful make release
         build.sh ended:      Wed Mar  8 02:16:35 AKST 2017
===> .
 tldr; it only takes an hour and a half to rebuild NetBSD on my i5. Not too shabby.

The next task is to build firefox, fluxbox and some other packages that make life under NetBSD easier.

I love the fact I can set this up to build on another computer and do things on my desktop while it runs. It's a lot better than doing everything all on one -it's almost decadent!

Friday, March 3, 2017

Home VM projects

A few months ago (Oct 2016) I got a second desktop as insurance in case my older one dies (it's well past warranty).

The first thing I did was to hook them up ethernet-to-ethernet with a crossover cable. The new computer is weaker than the old one, so I am slowly setting up the old one as a combination router and build machine.

I've done a couple of things with Virtualbox. The first was to create a Windows VM to use for Poser 11; it seems to work OK but I haven't played with it a lot. The second thing was to install the extention pack and play with hooking up an old usb HD to it, and share it between computers -running FreeBSD/UEFI on it. That didn't work terribly well. Both computers could see the drive, but the FreeBSD install got confused and after a couple of sessions wouldn't boot.

I am using VB on both computers. On the weaker computer, I have a Linux VM that has a self-compiled SIMH on it. Following this tutorial ( http://gunkies.org/wiki/Installing_4.3_BSD_on_SIMH ) I was able to get 4.3 up quickly, and was delighted to find out that I could set up tap networking and ftp back and forth to the machine -though I can't get telnet to work at all. I managed to get a few old GNU things to work. I've been trying to figure out how to 'upgrade' the vax780, but no luck yet. I think I simply am missing too much training and background info that people knew back then.

 I am playing with setting up tap instances on both; on the router I have tap interfaces set up (manually) and am connecting to qemu instances running there.

Today I set up an OI kvm machine to use as a build VM. Here's my latest OI build and not much has changed, honestly...a build still takes a little over two hours.

qemu commandline;

cat bin/hipster
qemu-system-x86_64 -vga std -global VGA.vgamem_mb=256 -smp 4 -m 5G -cpu host -enable-kvm -drive file=$HOME/qemu/x86/hipster17/36G.qcow2,media=disk,if=virtio,index=0,format=qcow2 -boot c -net nic,model=e1000 -net tap,ifname=tap0,script=no,downscript=no -vnc 10.42.0.1:3399&


Output in virtual machine;

random@vipster2017:~$ cd /code/illumos-gate/
random@vipster2017:/code/illumos-gate$ time ./nightly.sh illumos.sh

real    47m39.132s
user    129m2.518s
sys     27m36.835s
random@vipster2017:/code/illumos-gate$



I ran that as a regular user in the Hipster vm, not root.

Setting up /etc/rc.local to set up tap turned out to not be the greatest idea, so I'm using that script in $HOME/bin and calling it with sudo when I need a tap interface.

So, I'm making progress in setting up a home network of computers but I have a lot of organizing left to do.

automating zfs mounts -a quick and very dirty script

 #!/bin/sh for x in obj xsrc src pkgsrc pkgsrc/distfiles pkgsrc/packages pkg         do zfs create ext/$x zfs set mountpoint=/usr/$x ext/$x ...