Sunday, June 12, 2022

automating zfs mounts -a quick and very dirty script

 #!/bin/sh
for x in obj xsrc src pkgsrc pkgsrc/distfiles pkgsrc/packages pkg
        do zfs create ext/$x
zfs set mountpoint=/usr/$x ext/$x
done
#
#
for x in obj xsrc src pkgsrc
        do chown -R $USER.$GROUP /usr/$x
done
#
df -h
/bin/echo " "
ls -l /usr/|grep $USER

Wednesday, May 18, 2022

NetBSD stuff

 mk.conf:

MAKE_JOBS=      4
DEPENDS_TARGET= bin-install

 ---

VBoxManage setextradata "NetBSD-92amd" CustomVideoMode1 1920x1080x32

 vesa list

vesa 0x160

---

 

Saturday, January 8, 2022

Hacky tip for Illumos

 This seems to be the weekend to do all the virtualizers -so I've installed OpenIndiana (Hipster 2021-10) which can use UEFI boot now.

I made my hard disk too small so I created another one and then realized that I have no idea how to find out what the name for the disk is. 

Then I remembered -format lists the drives it can see. So:

root@openindiana:~# format -e
Searching for disks...done


AVAILABLE DISK SELECTIONS:
       0. c5t0d0 <VBOX-HARDDISK-1.0-36.00GB>
          /pci@0,0/pci8086,2829@d/disk@0,0
       1. c5t2d0 <VBOX-HARDDISK-1.0-32.00GB>
          /pci@0,0/pci8086,2829@d/disk@2,0
Specify disk (enter its number): ^C
root@openindiana:~#

So now I know I can add c5t2d0 to the end of a zpool create incantation.

As I say; hacky, but it works...


Qemu -hostfwd at last!

 I'm still trying to figure this one out, to be honest

Sparc SS-20 seems to be much improved over the last couple of years; I'm able to boot and install Solaris 7 without much trouble as long as I stick to one cpu and 512megs of ram.

The big big thing is that I've figured out the current (as of 2022) network syntax. 

Sorta.

Now instead of mucking with netdev and vlans I'm able to simply use the "-nic" parameter and put hostfwd directives there.

So here's the complete command for sparc:

qemu-system-sparc -M SS-20 -m 512 -hda (drive) -cdrom  (iso) -boot c -cpu "TI SuperSparc 60" -nic user,hostfwd=tcp::8023-:23

8023 could presumably be anything? to a degree -it didn't work when I tried "80023", though. 

I changed it to "tcp::23-:23" and that worked, but it seems like a bad idea -still, it can be done!


Wednesday, January 5, 2022

NetBSD on VB - no more hacks! (or at least a lot less)


 Normally doing a NetBSD desktop on VirtualBox involves a convoluted ritual on both host and guest. I still need to do VBoxManage for the host setup, but I've discovered something interesting. For the guest, all I need to do is specify a vesa setting, like this: 

menu=Boot normally:rndseed /var/db/entropy-file;vesa 0x160;boot

...and I get a nice, rich but readable console, and a 1920x180 desktop in X too; without configuring X in any way. This works in VBoxSVGA and VMSVGA. 

Best of all, I get a respectable sized console in full-screen mode -without X. Instead of a tiny 640x480 screen I get a console like this:


 
This is a game-changer! No more X (at least, it's optional), no more scaled mode. It's not perfect, but it's a serious improvement!
 
 

Wednesday, October 6, 2021

A quiet fall

So Windows 11 has dropped -and I've dropped Windows 10. 

I've been using Mint Linux 20.2 with a radeon no-fan (but 2gb) card and it works great for videos; not much else. 

I haven't built (or played with) NetBSD for a while so I set that up last night before I went to sleep; here's the results:

===> Summary of results:
     build.sh command:    ./build.sh -U -j 6 -x -X /home/random/nsrc/92/xsrc -O /home/random/nsrc/92/obj/amd64/ release sourcesets iso-image-source
     build.sh started:    Wed Oct  6 01:26:19 AKDT 2021
     NetBSD version:      9.2
     MACHINE:             amd64
     MACHINE_ARCH:        x86_64
     Build platform:      Linux 4.19.0-17-amd64 x86_64
     HOST_SH:             /usr/bin/sh
     No $TOOLDIR/bin/nbmake, needs building.
     Bootstrapping nbmake
     MAKECONF file:       /etc/mk.conf (File not found)
     TOOLDIR path:        /home/random/nsrc/92/obj/amd64/tooldir.Linux-4.19.0-17-amd64-x86_64
     DESTDIR path:        /home/random/nsrc/92/obj/amd64/destdir.amd64
     RELEASEDIR path:     /home/random/nsrc/92/obj/amd64/releasedir
     Created /home/random/nsrc/92/obj/amd64/tooldir.Linux-4.19.0-17-amd64-x86_64/bin/nbmake
     Updated makewrapper: /home/random/nsrc/92/obj/amd64/tooldir.Linux-4.19.0-17-amd64-x86_64/bin/nbmake-amd64
     Successful make release
     Successful make sourcesets
     Successful make iso-image-source
     build.sh ended:      Wed Oct  6 03:33:21 AKDT 2021
===> .


Sunday, May 9, 2021

11 hours to build -current; what the hell?

 I'm not filing a bug because there's too many things that could be problems on my end:


  • This is in a virtualbox VM
  • I've seen other symptoms of HD failure on my host (I'm replacing the SATA with an SSD)
  • This is current compiled on current (9.99.82 compiled on 9.99.81)
  • Everything was sent to /usr/obj, which is a zfs volume. 


So -too many moving parts to report, basically. 

That said, here's the summary:

64,no-emul-boot,allow-multidot,bootimage=i386\;efiboot.img,platformid=efi,no-emul-boot NetBSD-9.99.82-amd64.iso cdrom

--- iso_image ---

mkdir -p -m 0755 /usr/src/obj/releasedir/images

/usr/src/obj/tooldir.NetBSD-9.99.81-amd64/bin/x86_64--netbsd-install -r  -c -m 444 NetBSD-9.99.82-amd64.iso /usr/src/obj/releasedir/images

iso-image ===> etc

make iso-image-source started at:  Sat May  8 14:02:24 AKDT 2021

make iso-image-source finished at: Sat May  8 14:42:32 AKDT 2021

===> Successful make iso-image-source

===> build.sh ended:      Sat May  8 14:42:32 AKDT 2021

===> Summary of results:

         build.sh command:    ./build.sh -j 5 -m amd64 -x release sourcesets iso-image-source

         build.sh started:    Sat May  8 04:05:23 AKDT 2021

         NetBSD version:      9.99.82

         MACHINE:             amd64

         MACHINE_ARCH:        x86_64

         Build platform:      NetBSD 9.99.81 amd64

         HOST_SH:             /bin/sh

         No $TOOLDIR/bin/nbmake, needs building.

         Bootstrapping nbmake

         MAKECONF file:       /etc/mk.conf

         TOOLDIR path:        /usr/src/obj/tooldir.NetBSD-9.99.81-amd64

         DESTDIR path:        /usr/src/obj/destdir.amd64

         RELEASEDIR path:     /usr/src/obj/releasedir

         Created /usr/src/obj/tooldir.NetBSD-9.99.81-amd64/bin/nbmake

         Updated makewrapper: /usr/src/obj/tooldir.NetBSD-9.99.81-amd64/bin/nbmake-amd64

         Successful make release

         Successful make sourcesets

         Successful make iso-image-source

         build.sh ended:      Sat May  8 14:42:32 AKDT 2021

===> .


automating zfs mounts -a quick and very dirty script

 #!/bin/sh for x in obj xsrc src pkgsrc pkgsrc/distfiles pkgsrc/packages pkg         do zfs create ext/$x zfs set mountpoint=/usr/$x ext/$x ...