Wednesday, July 31, 2019

timing

Two days after I decided to test the -currents:

--- iso_image ---
mkdir -p -m 0755 /usr/src/obj/releasedir/images
/usr/src/obj/tooldir.NetBSD-8.99.51-amd64/bin/x86_64--netbsd-install -r -p -c -m 444 NetBSD-9.0_BETA-amd64.iso /usr/src/obj/releasedir/images
iso-image ===> etc
make iso-image-source started at:  Wed Jul 31 06:18:35 AKDT 2019
make iso-image-source finished at: Wed Jul 31 06:20:21 AKDT 2019
===> Successful make iso-image-source
===> build.sh ended:      Wed Jul 31 06:20:21 AKDT 2019
===> Summary of results:
         build.sh command:    ./build.sh -j 4 -u -U -x -X /usr/xsrc release sets sourcesets iso-image-source
         build.sh started:    Wed Jul 31 03:06:36 AKDT 2019
         NetBSD version:      9.0_BETA
         MACHINE:             amd64
         MACHINE_ARCH:        x86_64
         Build platform:      NetBSD 8.99.51 amd64
         HOST_SH:             /bin/sh
         No $TOOLDIR/bin/nbmake, needs building.
         Bootstrapping nbmake
         MAKECONF file:       /etc/mk.conf
         TOOLDIR path:        /usr/src/obj/tooldir.NetBSD-8.99.51-amd64
         DESTDIR path:        /usr/src/obj/destdir.amd64
         RELEASEDIR path:     /usr/src/obj/releasedir
         Created /usr/src/obj/tooldir.NetBSD-8.99.51-amd64/bin/nbmake
         Updated makewrapper: /usr/src/obj/tooldir.NetBSD-8.99.51-amd64/bin/nbmake-amd64
         Successful make release
         Building sets from pre-populated /usr/src/obj/destdir.amd64
         Built sets to /usr/src/obj/releasedir/amd64/binary/sets
         Successful make sourcesets
         Successful make iso-image-source
         build.sh ended:      Wed Jul 31 06:20:21 AKDT 2019
===> .

...I have to build everything all over again. Somehow I don't mind.

Sunday, July 28, 2019

-currently in NetBSD 8.99...

===> Summary of results:
         build.sh command:    ./build.sh -j 4 -u -x -X /usr/xsrc release sets sourcesets iso-image-source
         build.sh started:    Sun Jul 28 10:03:40 UTC 2019
         NetBSD version:      8.99.51
         MACHINE:             amd64
         MACHINE_ARCH:        x86_64
         Build platform:      NetBSD 8.99.51 amd64
         HOST_SH:             /bin/sh
         MAKECONF file:       /etc/mk.conf
         TOOLDIR path:        /usr/src/obj/tooldir.NetBSD-8.99.51-amd64
         DESTDIR path:        /usr/src/obj/destdir.amd64
         RELEASEDIR path:     /usr/src/obj/releasedir
         Updated makewrapper: /usr/src/obj/tooldir.NetBSD-8.99.51-amd64/bin/nbmake-amd64
         Successful make release
         Building sets from pre-populated /usr/src/obj/destdir.amd64
         Built sets to /usr/src/obj/releasedir/amd64/binary/sets
         Successful make sourcesets
         Successful make iso-image-source
         build.sh ended:      Sun Jul 28 13:39:36 UTC 2019
===> .

...time's wonky because I didn't set the timezone properly; but it took 3.5 hours to (re)build NetBSD-current from NetBSD current in VirtualBox 6.


Sunday, July 7, 2019

Setting up FreeBSD 12 in Virtualbox 6, 2019

VirtualBox has come a long way since I started using it 11 years ago!

In that time, FreeBSD has put in a lot of spit and elbow grease and make the process of using it as a guest operating system pretty smooth for a BSD.

FreeBSD has also switched package systems in that time too -going from the aging pkg_* tools to using the newly written pkgng system.

I don't write often because I have settled into a pretty dull routine; WSL, or Mint, and the occasional NetBSD vm, with some retrocomputing mixed in from time to time. Nothing worth writing about, honestly.

Frustrated with trying to compile an update for NetBSD, I decided to take FreeBSD out for a spin. While I do play with FreeBSD from time to time (not as much as Net) I hadn't really taken a very close look at how well it works with VMs these days.

For the most part I've worked with connecting to my VMs with ssh, and hacking together decent resolutions either with Mate's tools or custom xorg.confs. Not wanting to take excessive amounts of time waiting for compiles and being curious, I just dove right in to pkgng, Virtualbox, and Mate.

I created a FreeBSD 12/amd64 virtual machine and ran through the installation from iso -nothing major there.

After that was set up, I got pkgng to work. That simply meant running pkg and then "pkg update"

From there I installed the xorg, virtualbox-ose-additions, mate and slim packages. Later I found I needed to add fuse, though I'm not sure what for at this point -mounting, maybe?

So ...pretty simple so far; after that some configuration needs to take place.

For slim, you need something in ~/.xinitrc. Since I'm running Mate I only have one line in mine:
exec mate-session

For virtualbox I've added the following to /boot/loader.conf:

fuse_load="YES"

And I made the following changes to /etc/rc.conf to get everything working:

dbus_enable="YES"
hald_enable="YES"
slim_enable="YES"
vboxguest_enable="YES"
vboxservice_enable="YES"


I've also set up codeblocks, firefox and vlc as well.

I used Mate's hardware tool (graphics) to set up a decent resolution and saved it as a local user. I wasn't able to save it globbally, which is annoying but I can cope with. I don't have sound working, but I'm confident I'll get it if I ever need it.

My middle mouse button works, though -so FreeBSD already has one over on Mint.

I wasn't able to get shared folders to mount, but I found a nice post on the FreeBSD forums that gave me the following line:

sudo mount -t vboxvfs -o rw,gid=1001,uid=1001 vmshare $HOME/windowsDir

Change the share ("vmshare") name and the destination and it works just fine, albeit a little "ghetto" for 2019.

I had a NetBSD VM set up for my retrocomputing (simh) environment -still have it, actually -but I think I'll set this up too, and maybe even try recompiling a system from scratch sometime in the future.

One thing I'll make a note of -I tried the same set-up with vmware player but couldn't set the resolution above 1280. Installed their tools, did some things I found on the google -none of it worked so I went back to my VB VM ...which did.

automating zfs mounts -a quick and very dirty script

 #!/bin/sh for x in obj xsrc src pkgsrc pkgsrc/distfiles pkgsrc/packages pkg         do zfs create ext/$x zfs set mountpoint=/usr/$x ext/$x ...