Today I tested out building NetBSD 7 on a NetBSD 6 KVM virtual machine.
Here's the command line for starting the vm:
===
qemu-system-x86_64 -smp 4 -cpu host -enable-kvm -m 2048 -vga std -vnc :0 -drive file=$PWD/nbsd/wd01.img,index=0,media=disk,format=raw -net nic,model=e1000 -net user -redir tcp:5550::22 &
===
here's the post-build summary from build.sh:
===
build.sh command: ./build.sh -O /usr/obj -U -j 4 tools kernel=RND0 modules distribution sets
build.sh started: Mon Sep 14 16:58:05 AKDT 2015
NetBSD version: 7.0_RC3
MACHINE: amd64
MACHINE_ARCH: x86_64
Build platform: NetBSD 6.1.5 amd64
HOST_SH: /bin/sh
MAKECONF file: /etc/mk.conf (File not found)
TOOLDIR path: /usr/obj/tooldir.NetBSD-6.1.5-amd64
DESTDIR path: /usr/obj/destdir.amd64
RELEASEDIR path: /usr/obj/releasedir
Updated makewrapper: /usr/obj/tooldir.NetBSD-6.1.5-amd64/bin/nbmake-amd64
Tools built to /usr/obj/tooldir.NetBSD-6.1.5-amd64
Building kernel: RND0
Build directory: /usr/obj/sys/arch/amd64/compile/RND0
Kernels built from RND0:
/usr/obj/sys/arch/amd64/compile/RND0/netbsd
Building kernel modules for NetBSD/amd64 7.0_RC3
Successful build of kernel modules for NetBSD/amd64 7.0_RC3
Successful make distribution
Building sets from pre-populated /usr/obj/destdir.amd64
Built sets to /usr/obj/releasedir/amd64/binary/sets
build.sh ended: Mon Sep 14 18:08:47 AKDT 2015
===
Testing and installing it now -90 minutes isn't too shabby for a VM build. The host machine barely felt it, btw; no real noticeable performance hit.
===
I blitzed the install by following the instructions on the guide, but that doesn't matter that much -I found out what I wanted to know.
Subscribe to:
Post Comments (Atom)
automating zfs mounts -a quick and very dirty script
#!/bin/sh for x in obj xsrc src pkgsrc pkgsrc/distfiles pkgsrc/packages pkg do zfs create ext/$x zfs set mountpoint=/usr/$x ext/$x ...
-
Two days after I decided to test the -currents: --- iso_image --- mkdir -p -m 0755 /usr/src/obj/releasedir/images /usr/src/obj/tooldir.Net...
-
KVM commandline (on host): screen -S qemu06 /usr/local/bin/qemu-system-x86_64 -enable-kvm -cpu host -smp 4,cores=4,maxcpus=8 -m 2048 -net ...
-
make iso-image started at: Thu Feb 25 20:50:56 AKST 2021 make iso-image finished at: Thu Feb 25 20:51:03 AKST 2021 ===> Successful make ...
No comments:
Post a Comment